Credit score unavailable

Incident Report for Strise

Resolved

This incident has been resolved.
Posted Nov 25, 2025 - 19:12 CET

Update

The issue should now be resolved from our provider but we will continue to monitor the performance
Posted Nov 25, 2025 - 17:00 CET

Update

We are still seeing some timeouts towards the credit score API provider and continue to monitor the situation
Posted Nov 25, 2025 - 15:44 CET

Monitoring

We are now seeing successful credit score requests from our provider, but will continue to monitor the situation closely
Posted Nov 25, 2025 - 15:37 CET

Investigating

Our credit score provider is experiencing some issues leading to credit scores currently not being available
Posted Nov 25, 2025 - 15:22 CET