Credit reports unavailable

Incident Report for Strise

Resolved

The incident has been resolved and credit reports are now available to order.
Posted Nov 13, 2025 - 12:50 CET

Identified

We're experiencing issues with our credit report supplier. As a result, new credit reports can not be ordered.
Posted Nov 12, 2025 - 13:42 CET
This incident affected: Application.