Application Downtime & High CPU Usage

Incident Report for Strise

Resolved

The issue has been identified and fixed.
Posted Feb 17, 2025 - 12:48 CET

Investigating

The application experienced intermittent downtime accompanied by a significant CPU usage spike. Initial reports indicated that the app was down, and further investigation revealed that synchronous Mixpanel requests (which was down at that point in time) were not being handled gracefully. This led to blocking calls, repeated retries, and oversized log entries. Additionally, a premature backend release introduced errors when fetching sidepanel entities.
Posted Feb 17, 2025 - 12:11 CET
This incident affected: Application.