Minor server disruption

Incident Report for Strise

Resolved

This incident has been resolved.
Posted Sep 30, 2022 - 12:49 CEST

Identified

Some functionality may be a bit slow, but we'll be back to normal speed very soon.
Posted Sep 30, 2022 - 11:31 CEST
This incident affected: Application and API.