Norwegian beneficial owner data inconsistencies

Incident Report for Strise

Resolved

This incident has been resolved.
Posted May 16, 2025 - 15:18 CEST

Update

We are continuing to monitor for any further issues.
Posted May 16, 2025 - 13:26 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 16, 2025 - 13:20 CEST

Identified

We’ve updated Norwegian companies with new shareholder data from Aksjonærreegisteret 2024. Beneficial owners are still based on 2023 data, so there are inconsistencies between shareholders and beneficial owners.

We expect to resolve the issue within today (Friday).
Posted May 16, 2025 - 08:16 CEST
This incident affected: Web, Application, and API.