- Degraded data freshness for Finnish and Swedish UBO data – Incident details

All systems operational

Degraded data freshness for Finnish and Swedish UBO data

Resolved
Degraded performance
Started about 1 month agoLasted 11 days

Affected

Data Freshness

Degraded performance from 11:00 AM to 9:00 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Update
    Update

    We received a full dump of Finnish data yesterday but are still not receiving delta updates. We are continuing to push our provider to solve this issue as quickly as possible.

  • Identified
    Identified
    No new updates received on Finnish and Swedish UBOs since 30th and 28th of March, respectively. We've reported the issue to our data vendor and are awaiting a fix on their end.