- More monitoring alerts than usual today – Incident details
All systems operational
More monitoring alerts than usual today
Resolved
Operational
Started about 1 month agoJune 11, 2026Lasted 1 dayJune 11, 20261:19 PMJune 12, 20261:52 PMUTC
Affected
Monitoring
Operational from 1:19 PM to 1:52 PM
Updates
Resolved
UTC
Resolved
UTC
This incident has been resolved.
Monitoring
UTC
Monitoring
UTC
There might be more alerts than usual today. We've restored screening coverage for a small group of companies and improved the precision of our sanctions matching. Accumulated and corrected changes are being delivered as a one-time batch.