- Missing data updates from external data provider (FI & SE) – Incident details

All systems operational

Missing data updates from external data provider (FI & SE)

Monitoring
Partial outage
Started 13 days ago

Affected

Data Freshness

Partial outage from 5:00 AM to 6:01 PM, Operational from 6:01 PM to 12:00 AM

Updates
  • Monitoring
    Monitoring

    Data updates are now coming through for both Finnish and Swedish data. We've backfilled the data since the incident started and the data in Strise should now be updated. We will continue to monitor the situation to ensure the data sync remains operational.

  • Identified
    Identified

    We are currently experiencing an interruption in data delivery from one of our external data providers, Valu8. As a result, you may notice that all Finnish data (with the exception of Finnish Financials) and Swedish ownership data have not been updated over the past week. We are in close dialogue with their technical team and have escalated the issue, as this falls short of the service levels we expect to deliver to you. We are monitoring their progress daily and will keep you updated as soon as the data flow is stabilized.