Scheduled maintenance on NO ownership data
Scheduled for May 27, 2024 at 2:15 PM – 10:15 PM
Affects
Application
Under maintenance from 2:15 PM to 10:15 PM
Completed
May 27, 2024 at 10:15 PMCompleted
May 27, 2024 at 10:15 PMThe scheduled maintenance has been completed.
In progress
May 27, 2024 at 2:15 PMIn progress
May 27, 2024 at 2:15 PMScheduled maintenance is currently in progress. We will provide updates as necessary.
Update
May 27, 2024 at 1:15 PMUpdate
May 27, 2024 at 1:15 PMMaintenance will begin as scheduled in 60 minutes.
Planned
May 27, 2024 at 1:10 PMPlanned
May 27, 2024 at 1:10 PMWe will be undergoing scheduled maintenance during this time.