- Application Downtime & High CPU Usage – Incident details

All systems operational

Application Downtime & High CPU Usage

Resolved
Major outage
Started 11 months agoLasted 37 minutes

Affected

Application

Major outage from 11:11 AM to 11:48 AM

Updates
  • Resolved
    Resolved

    The issue has been identified and fixed.

  • Investigating
    Investigating

    The application experienced intermittent downtime accompanied by a significant CPU usage spike. Initial reports indicated that the app was down, and further investigation revealed that synchronous Mixpanel requests (which was down at that point in time) were not being handled gracefully. This led to blocking calls, repeated retries, and oversized log entries. Additionally, a premature backend release introduced errors when fetching sidepanel entities.